GlobalProtect agent stuck at connecting stage on macOS
Symptom
- New GlobalProtect installation
- Issue is seen only on macOS, connectivity works fine on Windows operating systems
- GlobalProtect Agent stuck at the connecting stage on macOS with the following message (though on certain occasions the message does not appear):
- You may also encounter a message indicating "System Extension Blocked"
Cause
Starting in macOS High Sierra 10.13 Apple introduced a new feature that requires user approval before loading newly-installed third-party kernel extensions (KEXTs). Additionally, Technical Note TN2459 from Apple indicates, "this feature enforces that only kernel extensions approved by the user will be loaded on a system.
When a request is made to load a KEXT that the user has not yet approved, the load request is denied and macOS presents the alert with a System Extension Blocked message.
Resolution
- Enable Palo Alto Networks as a trusted developer.
- Launch System Settings.
- Select General > Login Items & Extensions
- Under Allow in Background find "Palo Alto Networks" in the list of applications.
- Slide the toggle to allow Palo Alto Networks to make changes and modify preferences.
Another Approach
If the above method does not work, another procedure to try is to go to Settings in the GPVPN app and click the "Sign Out" button in the General tab. Then try to connect again.