Dealing with nested INBOXes in Apple Mail
Suppose you see multiple INBOXes, nested under the real INBOX in Apple Mail. What causes this and what can you do about it?
Cause
We've generally seen this happen to people with the following details:
- Check mail with multiple Apple devices
- Typically at least one Mac OS X computer and at least one iOS portable device
- The various devices have different settings for the "IMAP Path Prefix"
If one mail program thinks the Sent folder has a server-side name of "Sent Messages" and the another mail program thinks the Sent folder has a server-side name of "INBOX.Sent Messages", the programs can get confused... especially if the programs synchronize with each other directly, in addition to synchronizing with the server.
Typically it is Apple Mail's "special" folders that become mis-synchronized like this: Sent, Drafts, Trash, or Junk(Spam) email folders.
Solution
The best way to deal with this is to (first) fix the configuration of your mail programs, and (second) clean up the nested folders.
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Fix mail programs
Go to each mail program on each device, and ensure that that all are set to use an IMAP Path Prefix of "INBOX".
- iPhone instructions are here: Set Up MIT IMAP email on iPhone or iPod touch
- In Mail, use the menu Mail > Preferences > Accounts, choose your IMAP account from the list, and go to the Advanced tab. Set IMAP Path Prefix to INBOX
Once this change is in, test your program: make sure the special "Sent", "Drafts", "Trash", and "Junk" folders work the way they should. If necessary, re-configure your program until the special folders work.
- For example, if Sent messages are going to the wrong folder, Apple Mail allows you to choose the folder you want, and then use the menu Mailbox > Use this mailbox for > Sent
Clean up the nested folders
When deleting these nested folders, it is best to start from the bottom.
- Review the bottom-most child folders. If you want to save messages, transfer those messages to a more appropriate top-level folder.
- Delete from the bottom. Delete the bottom-most child. Then try to delete its immediate parent.
- One possible confusion: it is possible for intermediate folders to be "virtual" - to not fully exist, to exist only for the purpose of holding a child, and to vanish when the child is deleted. If you try to delete a folder and the mail program won't let you, this probably means you are trying to delete a folder that doesn't really exist.
- If this happens, try quitting and re-opening the mail program, to force it to re-scan the server folders.