Access Keys:
Skip to content (Access Key - 0)

Data and Reporting Services - Using BrioQuery 6 via Citrix on Mac OS X

Information on this page may be obsolete. Try:
Citrix Receiver for Macintosh Installation and First Launch

On this page:

Overview

BrioQuery does not have a desktop version for Mac OS X machines. Citrix is a PC emulator that allows you to run the PC versions of MIT's enterprise applications (BrioQuery, Coeus, Adonis, Roles, SumMIT) on your Mac OS X.

You must register for Citrix before you can install and use it.

Full instructions for installing Citrix are also on the Citrix home page Certificates as well as provided below.

Note: To use Citrix, your Kerberos password cannot be more than three years old. If your password exceeds this age limit, you need to change your Kerberos password

Installing Citrix

Once you have registered for Citrix:

  1. Go to the MIT Citrix home page
    Result: The Citrix Welcome page displays.
    Citrix Welcome page

  2. Click on ICA Client for Mac OS X systems under the "Metaframe XP Message Center" heading.
    Result: The Downloading MacICA_OSX_dmg.zip window displays.
    Download options screen

  3. Select Open using StuffIt Expander and click OK.
    Result: The folder MacICA_OSX_dmg and the file MacICA_OSX_dmg.zip will appear on the desktop.
    Downloaded folder

  4. Double-click the MacICA_OSC_dmg folder.
    folder

    Result: The folder will open.
    Folder contents

  5. Double-click MacICA_OSX.dmg (the one with the hard drive icon.)
    Hard drive icon

    Result: The Citrix ICA client folder will open,
    Folder opens

    and a Citrix ICA Client volume will be mounted on the desktop.
    Volume mounted on desktop

  6. Drag the Citrix ICA Client folder icon from the open folder window on your desktop to the Applications folder in your hard drive:
    Client folder icon
    Result: The Citrix ICA Client folder will now appear in your Applications folder.
  7. Close all windows that have been opened during the Install process.
  8. Drag the following files/folders from your desktop (created during the Install) to the Trash:
    • MacICA_OSX_dmg folder
    • MacICA_OSX_dmg.zip
    • Citrix ICA Client
      Files/folders to be deleted
      Result: The files that are no longer required will be deleted.
  9. Open your browser, and go to the MIT Citrix home page.
    Result: The Citrix Welcome page will appear; your username should be displayed in the Login box.
    Welcome page

  10. Click Login.
    Result: The Citrix Applications page will appear.
    Applications screen

  11. Select one of the applications by double clicking on its icon (e.g., BrioQuery).
    Note: You will only be able to access applications for which you are authorized.
    Result: The first time you use Citrix, the Citrix Client Software License Agreement will appear.
    License agreement screen
  12. Click Accept.
    Result: A connection will be made to the Citrix Server. The Windows2000 Advanced Server Log on screen appears.
    Log in screen

  13. Enter your Kerberos username and password and click OK.
    Result: The application you selected will open.

When you click on BrioQuery (or any other application) on the Citrix applications page, a temporary launch.ica file appears on your desktop which will disappear if you click on it or end your session. Citrix assumes that you will launch applications from the Citrix website. If you do not wish to go to the Citrix website each time you want to launch an application, you need to edit the temporary launch.ica file(s). To do this;

  1. Once you have the file on your desktop, hold down the Control key and click on the file with your mouse cursor.
  2. Go to Open With > Other...
  3. Navigate to the TextEdit.app which should be in your Applications folder and click Open.
  4. Once you have the launch.ica open, look for the line that has RemoveICAFile=yes and change the "yes" to "no".
  5. Save the file and quit TextEdit.

You should now be able to double-click the .ica file and it should open the Citrix client, run as usual, and remain once you quit out. If you use Citrix for more than one application, you should rename the launch.ica for each when you download and edit it, e.g., "Brio.ica," "Coeus.ica," "Roles.ica" etc. so that you will know which launcher to use for each application.

Using Citrix

When using BrioQuery via Citrix on a Macintosh, you are actually using BrioQuery for Windows and not BrioQuery for the Mac. BrioQuery for Windows is the same as BrioQuery/Macintosh as far as features and commands, however there are some differences since you are accessing BrioQuery via Citrix. Below are some differences you will encounter:

Downloading BrioQuery Templates:

Since you'll be using BrioQuery 6 for Windows via Citrix, be sure to download the PC versions of BrioQuery templates from the Data Warehouse website. Both versions will work, but the formatting is different on the two platforms so font size and pagination may be different.

Changing the Window Size:

BrioQuery in the Citrix window cannot be maximized to the fill the screen by using the + sign in the upper left corner of the Citrix window or by using the Maximize button in the top right corner of the BrioQuery application window. If you want to make the window larger, do the following:

  1. Go to the MIT Citrix home page and log in.
    In the Applications area under "Citrix MetaFrame XP" click on the Tools icon:
    Tools icon
    Result: The Settings dialog box displays.
    Settings

  2. Under "Connection Preferences: Window size" specify a custom size:
    Note: We suggest that Mac OS X BrioQuery users set a custom size of 1024 x 768.
  3. Click Submit.
    Note: If the Submit button doesn't appear in the window, use the scroll bar on the right side to scroll to the bottom of the Settings window.
  4. Back in the Applications area, click on the BrioQuery icon to open the BrioQuery application. After entering your user name and password, the Brio Intelligence welcome dialog box displays in which you choose either to create a new query or open an existing query.

Keyboard Shortcuts

Since you're running BrioQuery for Windows, make sure you use the BrioQuery (Windows) keyboard shortcuts rather than the BrioQuery (Macintosh) shortcuts. For example, to open a file, press control-O

Context-sensitive Menus

To access the BrioQuery context-sensitive menus, place your pointer on the item, then press option-click.

Opening and Saving Files

The Open and Save dialog boxes do not display the name of your local hard drive(s) but instead display drive letters and terms used in Windows (e.g., Local Disk [C:]). Your local desktop hard drive is the "V" drive. One of the items in the popup list in the Open or Save dialog box (C$ on 'Client'[V:]) gives you access to your startup drive, where you can navigate to your desktop folder or any other folder. You'll need to store any BrioQuery files you download or create on your own computer via the C$ on 'Client'[V:] path in order to open them in BrioQuery via Citrix.

To open or save a file:

  1. Go to either File > Open... or File > Save As....
    Result: A message displays, "Program requires READ access to the "C" drive which maps to the folder hdname:Users:user_folder (where hdname is the name of your hard drive and user_folder is the name of your account folder in the Users folder). Do you want to allow or deny READ access to this folder for the rest of the session?"
  2. Click Allow.
    Result: The Open or Save As dialog box displays.
  3. Click on the arrow to the right of the Program folder and select C$ on 'Client'[V:] from the list to go to your local hard drive.
    Result: The folders inside hdname:Users:user_folder display.
  4. Save the file.

You can disable the Citrix Read/Write Allow/Deny boxes referenced above. To do this:

  1. Open the Citrix ICA Client folder in your Applications folder, and start the Citrix ICA Client Editor application.
  2. On the upper menu bar, select the Options menu and choose Default Settings.
    Result: The Default Settings window will open.
  3. Select the Drives and Devices tab. Look for the line with the "C:" drive.
  4. Click the box in the Read column until it shows simply a pair of glasses, not a pair of glasses with a line through it or a question mark next to it.
  5. Do the same thing in the box in the Write column, clicking until it shows simply a pencil, not a pencil with a question mark next to it or an X through it.
  6. Click Save and exit the application.
    Result: When you launch Citrix applications in the future, it will not give you the prompts about allowing read or write access.

Note: You can't freely navigate your hard drive through the Open or Save As dialog boxes so you may want to keep all BrioQuery files in one folder. You may want to create a subfolder specifically to store your BrioQuery files. Otherwise you will have to navigate through C$ on 'Client'[V:] for each document.

Printing

Before printing for the first time from within Citrix, from the Citrix File menu, make sure that Print with Dialog is turned on:
File menu options

You need to go through some additional dialog boxes to print, unlike when you print using a Macintosh program on your local machine.

To print, In BrioQuery:

  1. Go to File > Print...
    Result: The BrioQuery (Windows) dialog box displays.
  2. Click OK.
    Result: The Macintosh Print dialog box displays.
    Note: If the Macintosh Page Setup dialog box displays, choose your printer from the Format for: popup list, then click OK.
  3. From the Print popup list, choose your printer, then click Print.
    Note: You may find that you cannot use "advanced" page setup functions (changing from portrait to landscape, scaling). We've been told that an upcoming release will fix this limitation. Printing to your local printer with the full functionality of your printer's capabilities should be seamless with the upcoming release. In the meantime, there is a temporary fix available. You will need to register your printer on the Citrix server. To do this, send your request to network@mit.edu and include the following information:
    • The zone you are in,
    • The make and model number of your printer,
    • The printer's IP address (if your printer has a unique name that appears in your local printer list, rather than the generic model name, you can put your printer's name in the message rather than its IP address).

Note for Mac OS X users: You will find the Print Center application in the Utilities folder in the Applications folder on your OS X. This replaces the OS 9 Chooser for setting up printers.

Related Links

Community

Documentation and information provided by the MIT Community


Last Modified:

January 26, 2016

Get Help

Request help
from the Help Desk
Report a security incident
to the Security Team
Labels:
brio brio Delete
brioquery brioquery Delete
citrix citrix Delete
datawarehouse datawarehouse Delete
m-hermes m-hermes Delete
mac mac Delete
macosx macosx Delete
osx osx Delete
data data Delete
ware ware Delete
house house Delete
warehouse warehouse Delete
c-citrix c-citrix Delete
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.
Feedback
This product/service is:
Easy to use
Average
Difficult to use

This article is:
Helpful
Inaccurate
Obsolete
Adaptavist Theme Builder (4.2.3) Powered by Atlassian Confluence 3.5.13, the Enterprise Wiki