Access Keys:
Skip to content (Access Key - 0)

Configure Thunderbird for use with MIT Exchange or MIT Office365 Mailboxes

Thunderbird can be used to check your MIT email over IMAP, regardless of which mail environment your account is in: Exchange 2013 or Office365. The vast majority of mailboxes at MIT, at the time of this writing, are in Exchange 2013, but mailboxes will be migrated to Office365 moving forward.

The following procedures revolve around the IMAP protocol.

It is also possible to sync Exchange email in Thunderbird over EWS using ExQuilla or Owl, but that is beyond the scope of this article.
Thunderbird fully supports MIT email in it's various forms out of the box.

Calendar and contact syncing require a free add-on, please read on below.

The screenshots that follow are of Thunderbird v. 78.10.2 (64-bit) running on Arch Linux.

Contents of this article:

Exchange 2013 Setup Procedure

Most users reading this article will have an Exchange 2013 mailbox. If you are unsure, you can check with IS&T.

  1. If this is the first time you are running Thunderbird, you should be greeted by the Add New Account prompt.

    If not, manually start this process by going to Edit > Account Settings (or hamburger menu > Account Settings), then clicking Account Actions then Add Mail Account.



  2. Fill in correct name, MIT email, and password, and click Continue.

    Thunderbird will try to use old IMAP account settings (see below), but this is WRONG. You will fix this in the next step.

  3. Click Manual Config, then fill in the settings as below.

    Setting Value
    Incoming server imap.exchange.mit.edu
    Port 993
    Connection type SSL/TLS
    Authentication Normal password
    Username MIT/kerb username


    Setting Value
    Outgoing server outgoing.mit.edu
    Port 465 or 587
    Connection type SSL/TLS
    Authentication Normal password
    Username MIT/kerb username




  4. Click on Advanced Config, then click OK on the Account Settings window to exit the Account Settings window, then click on your email inbox to let it populate.

    And you are all set!
    Make sure to change to Sent folder to Sent Items, and set up calendar and contact syncing! See relevant sections below.

Office365 Setup Procedure

Office365, and other modern mail providers such as Gmail, are moving towards using authentication methods that support two-factor authentication. Generally this means using OAUTH2.

MIT's Office365 implementation supports OAUTH2 authentication for IMAP, but we do not support this for SMTP. All SMTP is handled via outgoing.mit.edu as normal.

Thankfully Thunderbird added support for OAUTH2 in v. 77 (or v. 78 ESR).

  1. If this is the first time you are running Thunderbird, you will be greeted by the add account prompt.

    Otherwise, go to Edit > Account Settings (or hamburger menu > Account Settings), then click Account Actions then Add Mail Account.

  2. Enter in your email address and password.

    Click on Configure Manually, and enter in the following server data.

    Setting Value
    Incoming server outlook.office365.com
    Port 993
    Connection type SSL/TLS
    Authentication Normal password
    Username Full MIT email


    Setting Value
    Outgoing server outgoing.mit.edu
    Port 465 or 587
    Connection type SSL/TLS
    Authentication Normal password
    Username MIT/kerb username




  3. Hit Done.

  4. Now go into Edit > Account Settings and click on Server Settings under your MIT email account.

  5. Change Authentication Method to OAuth2



  6. Now go back to the Inbox tab, and click on the Inbox under your MIT email address.

  7. As thunderbird tries to check for email, a Touchstone authentication window will open.

    Log in as normal.



  8. Then grant Thunderbird full permissions to your email.



    You are all set!
Make sure to change to Sent folder to Sent Items, and set up calendar and contact syncing! See relevant sections below.

Recommended Post Setup Tasks

Sent Folders

By default most IMAP clients will use the "Sent" folder to save sent email. Microsoft however uses the convention "Sent Items". To save yourself some confusion and heartache later, you should set Thunderbird to respect this convention.

  1. Go to Edit > Account Settings, then go to Copies & Folders under your MIT email account.

  2. Under When sending messages, automatically: select the Other radio button, then in the drop down navigate to the Sent Items folder for your MIT email (note: not a local folder.)

Calendar and Contact Syncing

In order to make use of your Exchange Calendar and Exchange GAL (Global Address List), you must employ the use of a plugin called TbSync, which can be installed via the Add Ons manager in Thunderbird.

  1. Go to Tools > Add-Ons, then in the box marked Find more add-ons, search "TbSync".

  2. Click + Add to Thunderbird next the following Add-Ons:
    • TbSync
    • Provider for Exchange ActiveSync
    • And possibly Provider for CalDAV & CardDAV if you want to sync CalDav (calendar) or CardDav (contacts) data from another account, e.g. Gmail.





  3. Edit the Preferences for TbSync



  4. Add a new account by going to Account Actions > Add new account > Exchange ActiveSync.
    • If you have an Exchange 2013 mailbox, select Automatic configuration and enter your information.
    • If you have an Office365 mailbox, select Office365 and enter your information.



  5. TbSync will autodetect settings and add the account.

    Tick the Enable and synchronize this account box.

    Pick the things you want synced (calendar, contacts), pick a sync period, and run the sync by clicking Synchronize now.



    And you're all set!

Set Mail Sync to "Online Only" Mode

The default behavior in Thunderbird is to download a local copy of all email. If you do not want this to happen, you can achieve this like so:

  1. Go to Edit > Account Settings, then go to the Synchronization & Storage section under your MIT email account.

  2. Untick the option Keep messages in all folders for this account on this computer

Signing Email with Personal SSL Certificates

It is possible to use your personal MIT certificates to digitally sign your emails. This is generally only useful if others have the MIT CA certificate installed on their systems to validate your signature, and if your recipients are expecting messages from you to be signed.

  1. First you need to download a copy of your personal SSL certificate: either use Firefox to access https://ca.mit.edu/ca/, or use any browser with https://certassist.mit.edu/.

    Download a copy of your cert and remember the download password you set.

  2. Import this certificate into Thunderbird. Go to Edit > Preferences (or hamburger menu > Preferences), then to Privacy & Security, and scroll down to Certificates and click on Manage Certificates



  3. On the Your Certificates tab click on Import..., and select the certificate file you downloaded. At this stage you will need to enter in the download password you set before.



  4. Now you can pick this certificate to be used for signing or encryption. Go to Edit > Account Settings, then to End-To-End Encryption under your MIT email account.

  5. In the S/MIME section select your personal certificate.



  6. If you want you can also set signing email to be the default behavior. Otherwise you can do this per-message under the Options menu.

Additional Notes

Folder Subscriptions

If you do not see all the mail folders that you expect to see or if it looks like folders are missing, check to see that all of your folders are marked as "subscribed".

  1. Right-click your Inbox folder and choose Subscribe... from the menu.
  2. In the Subscribe window, put a checkmark on every folder that you want to appear in your folder list.
    Folders without checkmarks will be hidden and will not appear.

Refiles and Deletions

The IMAP protocol for refiling a message is two steps: copy the message to the new folder first, then delete the old copy of a message. The deletion is itself two steps - mark the message as "deleted", and then purge deleted messages after that. A mail program (such as Thunderbird) which is using this protocol will generally not display messages which have been marked as deleted.

However, Exchange clients such as http://owa.mit.edu will show messages which have been marked as deleted using IMAP.

This means that if you do a lot of refiling messages in Thunderbird, you may see the messages in both the new location and the old location. Or if you delete a message in Thunderbird, the message will not appear to be deleted in OWA.

The way to fix this is to use the "Compact Folders" command in Thunderbird, to remove messages that have been marked as deleted, before you visit your mail in OWA.

Thunderbird will periodically suggest that you compact your folders. It is recommended that you do this.

Secondary Account

(Note: It is unclear if this still necessary, but this section is kept for historical purposes.)

When adding the Exchange account as a secondary account, verify that the correct email address, or a specific Reply-To address is set:

  1. Go to the Tools menu on top and choose Account settings from the drop down menu.
  2. In the left pane highlight your username@exchange.mit.edu account.
  3. In the right pane, in the Default settings section set your address to username@mit.edu or set a specific Reply-To address
  4. Click OK to save the changes.

Community

Documentation and information provided by the MIT Community


Last Modified:

June 25, 2021

Get Help

Request help
from the Help Desk
Report a security incident
to the Security Team
Labels:
c-thunderbird c-thunderbird Delete
thunderbird thunderbird Delete
exchange exchange Delete
c-exchange c-exchange Delete
configure configure Delete
exchange_over_imap exchange_over_imap Delete
email email Delete
o365 o365 Delete
office office Delete
365 365 Delete
imap imap Delete
ssl ssl Delete
cert cert Delete
digitally digitally Delete
sign sign Delete
encrypt encrypt Delete
online online Delete
copy copy Delete
sent sent Delete
items items Delete
calendar calendar Delete
contacts contacts Delete
caldav caldav Delete
carddav carddav Delete
activesync activesync Delete
tbsybc tbsybc Delete
tb tb Delete
smime smime Delete
s/mime s/mime Delete
mozilla mozilla Delete
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.
Feedback
This product/service is:
Easy to use
Average
Difficult to use

This article is:
Helpful
Inaccurate
Obsolete
Adaptavist Theme Builder (4.2.3) Powered by Atlassian Confluence 3.5.13, the Enterprise Wiki