Access Keys:
Skip to content (Access Key - 0)

How do I install Debathena manually?

Answer

Advanced Users Only
These instructions are intended for advanced users who have extensive experience maintaining a Debian or Ubuntu installation and wish to have full control over each step of the installation process.

In general, you are strongly encouraged to install Debathena using the installation script as described in: How do I install Debathena on my personal computer?

Package Managers

The instructions below use apt-get when installing packages. While it should technically be possible to use any package manager, we have found that aptitude's dependency resolver does not interact well with multiarch packages.

Graphical package managers, such as adept and synaptic do not easily support re-configuring the DEBIAN_FRONTEND environment variable. If you must use them, you may execute dpkg-reconfigure debconf to change the frontend to noninteractive, and change it back when you have installed Debathena.

Manual Installation

The following steps are to be executed on the command line as root.

Step 1. Install the repository’s public key.

wget -N https://debathena.mit.edu/apt/debathena-archive.asc;
apt-key add debathena-archive.asc

Step 2. Make the Debathena repository available to your package manager by adding the following two lines to /etc/apt/sources.list. Substitute the name of your distribution (e.g. squeeze, lucid, precise) for DISTRO.

deb http://debathena.mit.edu/apt DISTRO debathena debathena-config debathena-system
deb-src http://debathena.mit.edu/apt DISTRO debathena debathena-config debathena-system
Repository Components
The example above uses the main components of the Debathena repository. For additional components that may be available, please visit the Debathena homepage

Step 3. To give aptitude access to the new repository, run

apt-get update
These components contain the packages needed for a normal installation; further information about our repository structure is available at Debathena repository component options.

Step 4. If you are using Ubuntu, you must also make sure that the Universe repository is enabled. This is the default setting in modern versions of Ubuntu.

Step 5. Ensure that the headers for your kernel are installed, by running the following command and checking for packages that begin with linux-headers.

dpkg-query -W 'linux-headers-*'

Typically, this is package named something like linux-headers-flavor where flavor is something like generic, or server. (Debian packages may look like linux-headers-2.6-amd64.)

Step 6. Install the openafs-modules-dkms package, which will automatically compile and install OpenAFS modules for all installed kernels on your machine (provided headers are available).

env DEBIAN_FRONTEND=noninteractive apt-get install openafs-modules-dkms

Note: If you are running an ancient distribution (Debian 5.0 or earlier, or Ubuntu 9.04 or earlier), this package will not be available. You will need to instead install the openafs-modules-source package, and build the module by hand.

Step 7. Now you can install Debathena packages. The following will give you the recommended set of packages; other metapackages are also available at Which Debathena metapackage should I install?.

env DEBIAN_FRONTEND=noninteractive aptitude install debathena-standard

Step 8 If you are using Debathena-login, Debathena-login-graphical, or Debathena-workstation, and want to configure access controls, or are using Debathena-standard and have a local username different from your Athena username, or want to do other supported customizations, see Customizing Debathena.

Step 9 Please subscribe to our announcement list, so that we can send you announcements about changes in the project and important security upgrades.

blanche debathena-announce -a $USER

IS&T Contributions

Documentation and information provided by IS&T staff members


Last Modified:

November 12, 2016

Get Help

Request help
from the Help Desk
Report a security incident
to the Security Team
Labels:
c-debathena c-debathena Delete
debathena debathena Delete
manual manual Delete
install install Delete
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.
Feedback
This product/service is:
Easy to use
Average
Difficult to use

This article is:
Helpful
Inaccurate
Obsolete
Adaptavist Theme Builder (4.2.3) Powered by Atlassian Confluence 3.5.13, the Enterprise Wiki