Access Keys:
Skip to content (Access Key - 0)

Touchstone Duo Error - Remember device for 30 days - cookie error

1. Earlier Reports: I clicked "Remember this device for 30 days" and now when I try to access a resource through Touchstone, I get a Touchstone error that says this site requires cookies:

We have discovered an issue where the browser extensions for Dragon NaturallySpeaking causes Duo/Touchstone to fail. Turning off this extension will resolve the issue and allow the user to authenticate properly.

2. Recent Reports: Dragon and Touchstone (whether or not "Remember this device for 30 days" is selected or not) results in a Touchstone error that says this site requires cookies:

Error Text


MIT Touchstone Identity Provider Error

The Touchstone Identity Provider encountered an error while processing your request.

This service uses cookies. Please make sure that cookies are enabled in your web browser, return to the web server ou were trying to access, and try again.

To Disable Extensions

NOTE: it is not possible to work around the behavior by disabling Dragon extensions, setting Duo to "remember for 30 days", then enabling Dragon extensions again. Access to the Duo-protected site will fail on the next browser launch

NOTE: it is not necessary to select "remember for 30 days" in order for Duo to fail.

IS&T Contributions

Documentation and information provided by IS&T staff members

Last Modified:

August 04, 2016

Get Help

Request help
from the Help Desk
Report a security incident
to the Security Team
duo duo Delete
touchstone touchstone Delete
error error Delete
cookies cookies Delete
c-duo c-duo Delete
naturally naturally Delete
speaking speaking Delete
naturallyspeaking naturallyspeaking Delete
identity identity Delete
provider provider Delete
service service Delete
extension extension Delete
extensions extensions Delete
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.
This product/service is:
Easy to use
Difficult to use

This article is:
Adaptavist Theme Builder (4.2.3) Powered by Atlassian Confluence 3.5.13, the Enterprise Wiki